x
x

Add a comment

Troubleshooting - Post Questions Here!

Just got my Keymander2 all set up and only my controller works.

I followed the setup instructions to a T, got it all powered up and nothing but my controller worked. No keyboard or mouse input connected. The keyboard lights up the caps and scroll lock(no num because it's a Tenkeyless) and the mouse(Corsair Scimitar RGB) just lights up and goes through the rainbow of rgb. I tried updating the controller firmware, tried switching the controller to usb mode and nothing worked. I'd love to give this thing a fair shot but it's pretty confusing to get all set up. :( Any help would be appreciated. Controller is a model 1708

07/26/2020 8:05 AM

Hi Bergauk,

Sorry we missed your post. The 1708 is completely compatible, so we need to check a couple other things. First, are you in Mode 1 on your Xbox One profile? Second, please check this post to force USB mode as it is the most common cause.

07/28/2020 11:04 AM

Reply to:

Hi Bergauk,

Sorry we missed your post. The 1708 is completely compatible, so we need to check a couple other things. First, are you in Mode 1 on your Xbox One profile? Second, please check this post to force USB mode as it is the most common cause.

Does it matter that it's a One X? Do I do it at the One X startup or the XBox green screen? Because I've tried it with both and neither seems to work. The controller vibrates and the console turns on as normal, but the light on the controller never turns on.


I also checked to see if I had dev mode activated and it is not activated.

07/28/2020 10:43 PM

Could you have try only plug the controller on K2 no keyboard and mouse


is it could work normally ?


07/29/2020 7:56 AM

Reply to:

Does it matter that it's a One X? Do I do it at the One X startup or the XBox green screen? Because I've tried it with both and neither seems to work. The controller vibrates and the console turns on as normal, but the light on the controller never turns on.


I also checked to see if I had dev mode activated and it is not activated.

The controller vibrating and not turning on the LED indicates it is in BT mode. It does not matter if it is Xbox One original, S or X model, just plug in when the screen with the microchip shows up on your X. Did you use the micro USB cable that came in the K2 box to connect the controller? Also, make sure the keyboard, mouse and external power are all disconnected from the K2 before you plug it back into the XB1.

07/29/2020 10:00 AM

Add a comment

Welcome,