x
x

Add a comment

Device: KeyMander 2

My mouse was working and is now not.

I have a glorious model O mouse that was working perfectly. Now my keymander only works when the mouse is not plugged in. When I do plug it in it makes a ringing noise and turns my controller and keyboard off. Can someone help?

08/06/2022 10:54 AM

Hello,


Are you utilizing the power port on the K2?

If so, try using a higher voltage power adapter 2.4A or greater preferably.


Did it just randomly stop working or was it after any updates?


What is the model number of your controller?


Has anything in your setup changed?

08/09/2022 3:59 PM

Reply to:

Hello,


Are you utilizing the power port on the K2?

If so, try using a higher voltage power adapter 2.4A or greater preferably.


Did it just randomly stop working or was it after any updates?


What is the model number of your controller?


Has anything in your setup changed?

It was working fine, some how I got it to work again. However, it stopped working again. I’m using a old gen controller and everything turns on when I plug in everything besides the mouse. When I do it with the mouse in order it doesn’t turn on at all…

08/14/2022 4:30 PM

Can someone please help?

08/23/2022 2:14 PM

Reply to:

Can someone please help?

Sorry for the delay, but we need the answers to the questions J asked in order to help.

What console are you on?

What is the model number of your controller?

Are you using a power supply connected the power port on the K2?

What firmware is loaded on your K2?

Did it just randomly stop working or was it after any updates?

Has anything in your setup changed?

09/06/2022 4:01 PM

Reply to:

Sorry for the delay, but we need the answers to the questions J asked in order to help.

What console are you on?

What is the model number of your controller?

Are you using a power supply connected the power port on the K2?

What firmware is loaded on your K2?

Did it just randomly stop working or was it after any updates?

Has anything in your setup changed?

I’m on series s. A old gen controller. My set up hasn’t changed. I don’t use the power on the keymander. I can get my set up to work, but I don’t understand why when I unplug my mouse and plug it back it, it stops working. In order for me to turn it back on i have to unplug everything and plug the mouse in like 40 times.

09/11/2022 8:51 AM

Reply to:

I’m on series s. A old gen controller. My set up hasn’t changed. I don’t use the power on the keymander. I can get my set up to work, but I don’t understand why when I unplug my mouse and plug it back it, it stops working. In order for me to turn it back on i have to unplug everything and plug the mouse in like 40 times.

It would be worth trying to use that power port along with a power adapter to rule out the possibility that the K2 may not be getting supplied with enough power to properly communicate with the mouse and keyboard together.


Try swapping the ports the keyboard and mouse is plugged into. Keyboard into mouse port and mouse into keyboard port and see if the issue follows.

09/22/2022 8:55 AM

Add a comment

Welcome,