Add a comment

Device: KeyMander 2

XBox S - Mouse won't look or aim

Hi There:

As noted above, I have an XBox Series S which was purchased a few months ago. I play mostly action/shooters and was just not happy with the controller, so I decided to try it with keyboard and mouse. Unfortunately, not all games which come with the XBox Game Pass Ultimate have native keyboard and mouse support, so I started to learn about K&M adapters. Off to Amazon I go to purchase a GameSir VX2 AimBox. It shows up, I install the app, hook up my keyboard and mouse, and... disappointment. Well, that's what I get for going cheap, I thought. Sent it back, and went back to Amazon. Not having learned my lesson, I opted again for GameSir, but this time the VX2 AimSwitch, the one with the half-keyboard and mouse. It arrived, I set it up and spent two days trying to get it to work with Mass Effect. Still no joy, sent it back.

So here we are today. I have purchased from Amazon, the IOGEAR KeyMander 2/Keyboard/Mouse/Headset Bundle - GE1337P2KIT3, and I am unable to convince the mouse (IOGEAR KORONA™ RGB Gaming Mouse), to look or aim. I had Ghost Recon Wildlands already loaded and luckily, (or maybe not) the KeyMander 2 app has a profile for that game, so I decided to give it a try. Let me first say that it sort of works. The profile in the app has the right stick mapped to WSAD, but it SHOULD be the left stick, so you might want to look into that, so I edited the profile so that WSAD now moves forward, backward and strafes left and right. The buttons on the mouse work: right button brings up sights, left button fires, wheel button changes weapons, etc., but movement of the mouse itself does nothing at all. Or rather so close to nothing at all as makes no difference. What DOES happen is: if I move the mouse forward, my character will take a tiny step forward, same with back, left and right. What I want it to do is: move mouse forward - look down, move mouse backwards - look up, move mouse left - look left, move mouse right - look right. The same with aiming when I have my sights/scope up. I have gone through the game settings and maxed out all the controller look sensitivities as recommended and the mouse DPI is set to 10000.

Incidentally, I have also tried with MechWarrior 5 and the KeyMander 2 configured for XBox S default and tried to edit those settings as well. No joy there either.

Oh, and the cable included with the device is USB-A to Micro USB, but XBox S requires USB-A to USB-C. You might want to mention that in your literature somewhere.


08/25/2022 1:20 PM

Add a comment