x
x

Add a comment

Device: KeyMander 2

Xbox One Controller Update - Keymander 2 No Long Works?

Hi forum,


There was a recent controller update for Xbox One controllers. I ran it because I was having an issue where there was no sound coming from my controller. I disconnected the controller from the Keymander 2, and plugged the controller directly into my xbox to run the update. Once completed, I reconnected the controller to the Keymander 2, however this time it would only vibrate and not connect.

I disconnected my keyboard and mouse to see if it would connect that way, and it did. The controller connects through the Keymander 2 without the keyboard and mouse just fine. I tried plugging in the keyboard and mouse again and the controller began to vibrate, with no light, again.


I made certain the controller was in USB mode, didn't work. I full-reset my xbox, didn't work. I unplugged-replugged the Keymander 2, didn't work. I unplugged-replugged every cable, didn't work. I connected my phone to the Keymander 2 via Bluetooth and ran a firmware update (v.1.2.116) then tried what every procedure I did before; didn't work. I figured the update was corrupted so I redid the firmware update via my PC, then ran the previous procedures again; didn't work.


Maybe it was the controller update? I tried plugging in a USB-only third-party controller that had worked before, that didn't work either.


I'm very unsure of what to do now. Any help?

10/06/2021 2:10 PM

Hi FoRealz,

We have updated all our Xbox One and Series X models without issue. For reference, 3rd party controllers are only compatible for Crossover mode, so you still need an original controller connected for K2 to function. Also, if you accidentally press F8 and switch into KM Direct Mode, the controller will not function or pass audio until F8 is pressed again and return to Keyboard Emulation mode. The easiest way to know is to open the K2 App and check the mode.

10/08/2021 11:34 AM

Add a comment

Welcome,