Add a comment

Device: KeyMander 2

Update firmware keymander 2

Its not updating and it keeps saying failed to update firmware

03/28/2020 1:27 PM

Does your phone support OTA (over the air) transfers via Bluetooth (most modern phones do)? I had the same issue initially but I just closed and reopened the app, connected to the device via Bluetooth, and tried the update again and it worked for me—said my firmware was updated. Try that and also post the firmware that the app says your device is currently on.

03/28/2020 2:02 PM


If your device is having problems staying connected to the OTA update server you can also update manually using a PC as explained here.  Alternately you can keep trying the OTA update, but after you connect to the K2 unit wait until it loads a profile and shows it on your library tab, then attempt the update.  It may take a couple attempts if you are losing connection, but it will usually still update even though it shows the connection failed.  If you have access to a PC, performing the manual update is faster and easier so I suggest that.

03/30/2020 11:33 AM

I have same problem before

just sign in with different e mail & it’s works

03/30/2020 8:01 PM

Add a comment